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INTRODUCTION

The GNSS receiver X5R / X5RT incorporates a GNSS antenna, a receiver, technology

Bluetooth® wireless, Wi-Fi, an internal LoRa radio available in 433 and 915 MHz 
frequencies with reception and transmission options, ideal as a base station or a quick-
setup integral RTK rover.

LEDs and sound alerts allow monitoring satellite tracking, radio reception, data 
logging status, WiFi mode, and power. Bluetooth mode provides wireless 
communication between the receiver and the user's mobile device (cell phone or 
tablet).

OVERVIEW

This manual describes how to configure and use a GNSS receiver model X5R / X5RT.
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1. GNSS RECEIVERS X5

1.1. GNSS RECEIVER X5R / X5RT

1.1.1. CONTENT

GNSS receiver model X5R

GNSS receiver model X5RT

ITEM CONTENT

GNSS RECEIVER
X5R / X5RT

TNC LORA 433
 / 915 MHz 
ANTENNA

PLATE FOR
MEASUREMENT OF

TNC CABLE 30CM
MALE-FEMALE

USB-C CABLE

ADAPTER

CASE
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1.1.2. HARDWARE COMPONENT AND FUNCTION

Front View X5R / X5RT
METTA TECHNOLOGIES S.A.C.

MULTIBAND GNSS RECEIVER
X5 SERIES

DATE: 
PRO.MAY 2025

2D32
MAC:

Bottom View X5R / X5RT
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ITEM COMPONENT COMPONENT

BUTTON

Power on: Press 2 - 3 seconds until the BAT LED lights up.

WiFi Mode: Press 1 - 2 seconds until it emits two beeps. Mode 
to configure and select the Standalone / Static, PPK, RTK LoRa, 
RTK NTRIP and Local NTRIP working method. Bluetooth mode:Press 1 - 2 seconds. Mode to configure and start the

working method with FindX5 or other field software. Turn off:Press 5-6 seconds until the device stops beeping
(after 5 beeps in total).

USB C PORT

USB Storage (Disabled) Battery
 charging: With an external battery or the power adapter
included.
Firmware update: Firmware update is allowed
available in Cloud X5. USB 
Storage (Enabled) Access to 
internal memory: Allows download of raw data.

BAT LED

Battery 
indicator Blue: 
Green: Yellow: 
Red:

NET LED

Wifi and Bluetooth 
Mode Blinking: Bluetooth not connected.
Solid: Bluetooth connected.
Fading: WiFi Mode.

BC LED
Charging indicator 
Red: Charging.
Blue: Charging completed.

BASE LED
Off: Rover Mode.
Blinking: Base Mode, searching for position.
Solid: Base Mode, position established.

RF LED
TX/RX Radio Frequency 
Off: Does not transmit or receive RTK corrections.
Blinking/solid: Transmits or receives RTK corrections.

RTK LED

Solution type indicator Off: 
Standalone or DGNSS
Blinking: Float
Solid: Fix.

SAT LED
Satellite indicator Off:Does not track satellites.
Blinking: The receiver is tracking at least 4 satellites.

INTERFACE
LoRa antenna installation interfaceLORA ANTENNA

LABEL OF
SERIAL X5

Unique serial number of each GNSS 
equipment. Example: “PEX5-00000”

LABEL OF
DATE AND MAC

Date: Month and year of production are indicated.
MAC: The MAC code for WiFi and Bluetooth connections is indicated.
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1.1.3. SOUND ALERT

ITEM EVENTS SOUND

POWER ON / RESTART Three beeps.

Two quick beeps and three slow beeps, in
OFF

total 5 beeps.

WIFI MODE Two beeps.

Continuous beeps until it obtains its
BASE MODE POSITION

position.

One beep every 10 seconds if it is
FILE RECORDING

recording a file.

In NTRIP base mode, incorrect credentials
NO INTERNET CONNECTION

of the WiFi, emits alert sounds.

Three quick beeps every 15 seconds if
RTK FIX

RTK Fix is achieved.
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1.2. NOAA CALIBRATED ANTENNA

1.2.1. GNSS RECEIVER DIAGRAM X5R / X5RT

Front view X5R / X5RT

Front view X5R / X5RT

1.2.2. METX5 CALIBRATED ANTENNA DRAWING

Brand Code: MET 
(Mettatec) Antenna Model: 
X5 Antenna Code: METX5 
Radome Code: NONE
Antenna Reference Point (ARP): Bottom of Antenna Mount (BAM) 
North Reference Point (NRP): Man-Machine Interface (MMI)

Antenna 
Type: METX5 NONE
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Download antex file METX5_NONE.atx

METX5 is the antenna calibrated by NOAA that includes phase center offsets 
(PCO) and phase center variations (PCV). The METX5 antex file helps us correct 
errors in GNSS measurements, improving the accuracy of positioning solutions.

1.2.3. ANTEX METX5

The X5R/X5RT GNSS receivers integrate the METX5 antenna. To ensure accuracy in post-
processing, import the antenna model into the software or update your library with the 
NOAA calibrated antennas.

Not all software supports NOAA calibrated antennas. Verify compatibility with the 
GNSS software provider or manufacturer.
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1.3. GNSS ANTENNA HEIGHT MEASUREMENT

The following describes how to measure the height of an antenna mounted on a tripod 
using 2 references for the measurement.

REFERENCE 1 (R1):

It is the point of intersection between the gray cover and the white body of the GNSS 
receiver. This marks the reference plane for measuring the antenna height.

Measurement procedure:

The height of the GNSS antenna is measured at an angle, from the control point to R1, 
using a tape measure. The value obtained is recorded as HR1.

Calculation of height to ARP
(Antenna Reference Point):

1.3.1. GNSS ANTENNA MEASUREMENT X5R – REFERENCE 1

Measurement to R1 – X5R
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1.3.2. GNSS X5RT ANTENNA MEASUREMENT – REFERENCE 1

 REFERENCE 1 (R1):

It is the point of intersection between the gray cover and the white body of the GNSS 
receiver. This marks the reference plane for measuring the height of the antenna.

Measurement procedure:

The height of the GNSS antenna is measured obliquely, from the control point to R1, 
using a tape measure. The value obtained is recorded as HR1.

Calculation of height to ARP
(Antenna Reference Point):

Measurement to R1 – X5RT
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1.3.3. GNSS X5R ANTENNA MEASUREMENT – REFERENCE 2

REFERENCE 2 (R2):

Corresponds to the upper edge of the measurement plate installed at the base of 
the GNSS receiver. This edge is located 12 cm from the center of the equipment's 
installation axis.

Measurement procedure:

The height of the GNSS antenna is measured at an angle, from the control point to R2
 (measurement plate), using a measuring tape. The value obtained is recorded as 
HR2.

Calculation of height to ARP
(Antenna Reference Point):

Measurement to R2 - X5R
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1.3.4. GNSS X5RT ANTENNA MEASUREMENT – REFERENCE 2

REFERENCE 2 (R2):

Corresponds to the upper edge of the measurement plate installed at the base of 
the GNSS receiver. This edge is located 12 cm from the center of the equipment's 
installation axis.

Measurement procedure:

The height of the GNSS antenna is measured at an angle, from the control point to R2
 (measurement plate), using a tape measure. The value obtained is recorded as HR2.

Calculation of height to ARP
(Antenna Reference Point):

Measurement to R2 - X5RT
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2. FINDX5 FIELD SOFTWARE
FindX5 is the comprehensive solution for easily managing and configuring your X5 
receivers (X5R / X5RT), centralizing geodetic tools, equipment configurations, and 
technical documentation on a single platform.

2.1. INTERFACE AND FUNCTIONS
FindX5 integrates three environments: Device (links X5R/X5RT receivers via WiFi/Bluetooth), 
Surveying (manages projects and coordinate systems for

surveying/stakeout) and Tools (access to cloud solutions and technical documentation).

2.1.1. DEVICE
The Device environment manages the
linked receivers (X5R/X5RT)
and allows you to configure their connection
via WiFi or Bluetooth.

Device Environment

ITEM COMPONENT DESCRIPTION

APPLICATION FindX5 application name.

Indicates the connection status (connected or disconnected to the
CONNECTION

GNSS receiver).

SELECT YOUR DEVICE Select the GNSS receiver linked by Bluetooth.

UPDATE Updates the list of linked receivers and new receivers.

Automatically connects to the newly
BLUETOOTH

linked GNSS receiver. Enters Bluetooth Mode.

Displays the GNSS receivers linked by Bluetooth.
LINKED DEVICES

Enters Bluetooth Mode.

Displays the GNSS receivers not linked by Bluetooth.
NEW DEVICES

Enters Bluetooth Mode.

WIFI CONFIG Connects to the GNSS receiver via WiFi. Enters WiFi Mode.
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ITEM COMPONENT DESCRIPTION

APPLICATION Application name FindX5.

SOLUTION

Solution type: Fix:Good reception of correction and RMS.
Floating: Regular reception of correction and RMS.
DGNSS: Submetric level positioning without correction.
Single: Autonomous metric level positioning without correction.

SATELLITES Indicates the number of satellites used / tracked.

RMS Root mean square error of the current positioning.

BATTERY Current percentage of the GNSS receiver battery.

WORKING MODE Current Mode or Working Method of the GNSS receiver.

DEVICE GNSS receiver connected.

2.1.2. DEVICE - VIA BLUETOOTH

Connection Via Bluetooth:

> Identify MAC of the GNSS receiver

> Pair the GNSS receiver with the mobile device via Bluetooth > Select 
linked GNSS receiver.

Bluetooth Environment – 
General Information
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Bluetooth Via Environment – Options Menu

ITEM COMPONENT DESCRIPTION

SELECT YOUR DEVICE GNSS receiver connected via Bluetooth.

BLUETOOTH Select to disconnect the GNSS receiver.

Status of time, position, RMS, Solution, DOP,
GNSS STATUS

signal-to-noise SNR and plan view.

SENSOR STATUS IMU sensor status (only for GNSS X5RT receiver)

Information on: battery level, voltage, version of
DEVICE INFO

receiver firmware and GNSS module version.

SETTINGS Specifies that WiFi mode is activated in Actions.

Allows the entry of NTRIP credentials for the
NTRIP CLIENT

GNSS rover receiver and connect to the NTRIP service.

Allows recording raw UBX data and storing it directly
PHONE LOGGING

to the user's mobile device. (X5 MOBILE PRO only)

Allows recording raw UBX data, stored in the
DEVICE LOGGING

GNSS receiver. (X5R / X5RT only)

ACTIONS Actions to Turn Off or Start.
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Options Menu - Via Bluetooth

GNSS STATUS SENSOR STATUS

DEVICE INFO SETTINGS NTRIP CLIENT

DEVICE LOGGING ACTIONS
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2.1.3. DEVICE - VIA WIFI

Connection Via WiFi (Access 01): >
 Link GNSS receiver Bluetooth Mode
> Enter Actions
> Select WiFi Config.
> Link the GNSS receiver with the mobile device via WiFi via WiFi.

Connection Via WiFi (Access 02): > 
Activate WiFi Mode with the power button by pressing for 1-2 seconds
> Link the GNSS receiver with the mobile device via WiFi

> Connected to the GNSS receiver's WiFi

> Enter WiFi Config (if it doesn't enter, you must deactivate the internet data of the 
mobile device)
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ITEM COMPONENT DESCRIPTION

RESTORE Restores the current working mode of the GNSS receiver.

SAVE Saves the selected and configured working mode.

EXIT Exits Wifi mode and continues to Bluetooth mode.

BATTERY Current battery percentage of the GNSS receiver.

MAC Identifier of the GNSS receiver.

SATELLITES Indicates the number of tracked satellites.

SOLUTION

Solution type: Fix:Good correction reception and good RMS.
Floating: Regular correction reception and RMS.
DGNSS: Submetric level positioning without correction.
Single: Autonomous metric level positioning without correction.

Via WiFi Environment – General Information

Via WiFi Environment – Options Menu

ITEM COMPONENT DESCRIPTION

SETTINGS
Selects and configures the working method 
(Standalone / Static, PPK, RTK LoRa, RTK NTRIP and 
Local NTRIP).

Allows the management of stored native data and
LOGGING

allows the enabling of transfer via USB cable.

SYSTEM

GNSS system information:Number of satellites tracked, solution type.
Position: Current positioning in latitude, longitude,
ellipsoidal height datum WGS84. 
Battery: Battery level, battery voltage.
Reset Factory Defaults: Factory default reset.
Firmware: current firmware version, and current version
of GNSS module.
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Options Menu - Via WiFi

SETTINGS

LOGGING SYSTEM
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ITEM COMPONENT DESCRIPTION

APPLICATION FindX5 application name.

SOLUTION

Solution type: Fix:Good correction reception and good RMS.
Floating: Regular correction reception and good RMS.
DGNSS: Submetric level positioning without correction.
Single: Autonomous metric level positioning without correction.

SATELLITES Indicates the number of satellites used / tracked.

RMS Root mean square error of the current positioning.

BATTERY Current percentage of the GNSS receiver battery.

INCLINATION Degrees of inclination with respect to the vertical axis.

PROJECT Project name. Example METTATEC

ARP HEIGHT Vertical height to the ARP.

2.1.4. SURVEYING

Surveying Environment – General Information
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Surveying Environment – Options Menu

ITEM COMPONENT DESCRIPTION

LOCATION
CURRENT

Refers to the current location of the rover.

POINT
RAISED

Refers to the raised point (blue/floating, green/fixed)

POSITION OF
BASE

Refers to the location of the correction base.

CONFIGURATION
SURVEY

Configures pole height, age restriction, Fixed solution restriction and enables IMU. Displays 
antenna displacement, allows you to view and download geoid model.

PROJECT Manages projects: Select, create a project. And allows the import of a
project by the cloud.

POINT LIST
AND STAKEOUT

Allows you to view the raised and/or imported points. Allows you to select the point to be 
staked out.

EXPORT Exports project points in CSV or KML format.

BASE MAP Google Vectorial Reference Map.

COORDINATES
OF POSITION

CURRENT

Shows the geodetic coordinates (Latitude, Longitude, Ellipsoidal Height, Geoidal Height 
and Orthometric Height), projection (East and North) of the survey, and for stakeout the 
displacements are added (East, North, Height)

MODE
STAKEOUT

VISUAL

Allows you to visualize the direction and distance of the stakeout of a point referred to the 
current location.

SYSTEM
INERTIAL (IMU)

Allows you to activate and deactivate the IMU of the rover equipment for surveys with 
inclined poles.

ZOOM AND

CENTERING OF
LOCATION

CURRENT

Allows an automatic zoom and centering referred to the current location. You will be able 
to see the raised points at the moment of recording.

MEASURE AND RECORD Allows you to measure and record the current location, editing the name and description of the point.

SYSTEMS OF
COORDINATES

Allows you to search and select a geodetic or projection coordinate system.
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Options Menu - Surveying

CONFIGURATION PROJECT
SURVEY

POINT LIST EXPORT
AND STAKEOUT

BASE MAP
VISUAL 
STAKEOUT 
MODE
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MEASURE 
AND RECORD

COORDINATE 
SYSTEMS

ZOOM AND CENTER 
CURRENT LOCATION
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2.1.5. TOOLS

ITEM COMPONENT DESCRIPTION

NTRIP CASTER Direct access to X5 Cloud to view NTRIP CASTER credentials.

Direct access to X5 Cloud to verify the planetary KP index of
K-INDEX

NOAA.

Direct access to X5 Cloud to convert to RINEX data with the APP
RINEX CONVERTER

RINEX CONVERTER.

X5R Documentation and usage tutorials for the GNSS X5R receiver.

Direct access to X5 Cloud for importing points with the
STAKEOUT TOOL

APP STAKEOUT TOOL

MERGE UBX FILE Direct access to X5 Cloud to unify UBX data.

X5RT Documentation and usage tutorials for the GNSS X5RT receiver.

Documentation and usage tutorials for the GNSS X5MOBILE receiver
X5MOBILE PRO

PRO.
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3. WORKING METHODS

The GNSS X5R / X5RT receivers include the following GNSS methods:

Static - Millimetric precision with post-processing)
PPK - Post-processing with native data)
RTK LoRa  - Centimetric precision in real time via radio)
RTK NTRIP - Centimetric precision in real time via internet)
NTRIP Local - Corrections for drones from a local base).

3.1. STANDALONE / STATIC

Definition: High-precision (millimetric) GNSS positioning method that

uses fixed receivers for an extended period to capture carrier phase data.

Main Applications:

Control points for engineering and construction (certified points before IGN). 
Geodetic networks (reference frames). Auxiliary points for photogrammetry and 
LiDAR.
Deformation monitoring (structures, land).

BASE
KNOWN POINT

GNSS RECEIVER / CORS

ROVER
POINT TO CALCULATE

GNSS RECEIVER
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A. DATA CONFIGURATION AND RECORDING

> Enter WiFi Mode

> Select Static Method (Standalone / Static) > Select 
recording interval of 1Hz (1s)

> Select all constellations except SBAS > 
Save configuration > Exit WiFi Mode > 
Enter Bluetooth Mode

> Enter Device Logging > 
Indicate the Data Name

> Start Logging > Stop Logging

It is recommended to use a Data Name of 4 to 8 alphanumeric digits without special
 characters.

The recording time should be reflected with the weight that can be monitored in 
Device Logging to guarantee the storage of satellite observation.

Autologging to enable automatic recording when turning on the pre-configured GNSS 
receiver in Static mode.
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B. DATA DOWNLOAD
GNSS receivers have 2 modes of Native Data download.

Mode 01: Download via WiFi >
 Enter WiFi Mode
> Logging Option
> Select Native Data
> Select download icon

> Indicate the storage path on the user's mobile device > Press Download

Mode 02: Download via USB
> Enter WiFi Mode
> Logging Option
> Activate USB ( Enable USB Storage
> Save configuration ( Save ) > Exit WiFi Mode ( Exit
> Connect the GNSS receiver to the PC

> A window will open with the internal memory of the GNSS receiver and a copy of the 
Native Data can be made

Mode 02 download is recommended when the files are very large or 
Mode 01 does not allow the download.
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3.2. PPK

Definition: High-precision (centimetric to millimetric) GNSS positioning 
method that combines measurements in motion with differential correction 
through post-processing.

Main Features:

Good accuracy (1-3 cm in optimal conditions) without the need for a real-
time connection.
Flexibility in the field, does not require a link with the base receiver.
Mandatory post-processing (between the base receiver and mobile receiver)

Main Applications:

Surveys with vehicles, drones, or moving equipment. Crop mapping 
and terrain analysis.
Georeferencing of aerial images (Photogrammetry/LiDAR) Dynamic 
stakeout and machinery control (Construction)

ROVER
POINT TO CALCULATE

GNSS RECEIVER

BASE
KNOWN POINT

GNSS RECEIVER / CORS
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> Enter Device Logging

> Enter Data Name > Start 
Recording ( Start Logging)
> Stop Recording (Stop Logging)

It is recommended to use a Data Name of 4 to 8 alphanumeric digits without special
 characters.

The recording time should be reflected with the weight that can be monitored in Device 
Logging to guarantee the storage of satellite observation.

Autologging to enable automatic recording when turning on the GNSS receiver 
preconfigured in Base PPK.

3.2.1. PPK BASE
A. DATA CONFIGURATION AND RECORDING

> Enter WiFi Mode

> Select PPK Method (PPK) > Select
 Base (Base)
> Save configuration (Save) > Exit
 WiFi Mode (Exit) > Enter 
Bluetooth Mode

By default, the recording interval of the PPK Base is 1 second.
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B. DATA DOWNLOAD

GNSS receivers have 2 modes of Native Data Download.

Mode 01: Download via WiFi

> Enter WiFi Mode
> Logging Option
> Select Native Data
> Select download icon

> Indicate the storage path on the user's mobile device > Press Download

Mode 02: Download via USB (See full procedure on page 29)
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3.2.2. PPK ROVER
A. CONFIGURATION AND DATA RECORDING

> Enter WiFi Mode
> Select PPK Method (PPK)
> Select Rover (Rover)
> Save configuration (Save)
> Exit WiFi Mode (Exit)
> Enter Bluetooth Mode

By default, the recording interval for the PPK Rover is 0.2 seconds.

> Enter Device Logging

> Indicate the Data Name > 
Start recording (Start Logging)
> Enter the Surveying environment

It is recommended to use a Data Name of 4 to 8 alphanumeric digits without special characters.

The recording time should be reflected with the weight that can be monitored in Device 
Logging to ensure the storage of satellite observation.

Autologging to enable automatic recording when turning on the GNSS receiver 
preconfigured in Rover PPK.
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B. PPK SURVEY
> Position the equipment at the point for 10 to 60 seconds 
> Press Measure
> Edit Point Name Point Name

> Edit Point Description > Verify collected points in 
Point List

It is recommended to verify the solution of the collected point in the best case up to a 
DNGSS solution, the number of satellites and position coordinates.

C. NATIVE DATA AND CSV DOWNLOAD

> Stop Logging

GNSS receivers have 2 modes of Native Data download.

Mode 01: Download via WiFi

> Enter WiFi Mode
> Option Logging
> Select Native Data
> Select download icon

> Indicate the storage path on the user's mobile device > Press Download
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Mode 02: Download via USB
(See full procedure on page 29)

In addition to the Native Data, export the CSV generated by FindX5 for processing
the data in Metta Office, necessary in PPK surveys.

> Select Export
> Indicate csv format

> Indicate the storage path on the user's mobile device > Press Download
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3.3. RTK LORA

Definition:

Real-time GNSS positioning method with centimeter-level accuracy, using 
corrections transmitted via radio frequency (LoRa) for dynamic applications.

Main Features:

Centimeter-level accuracy in real time (without post-processing).

RTK corrections transmitted via LoRa network (long range/low consumption). 
Ideal for environments without cellular or internet coverage.

Main Applications:

Precise surveying for photogrammetry, LiDAR, bathymetry, among 
others. Agile surveying for precision agriculture, forestry, and cadastre.
 Auxiliary points for construction and alignment of infrastructures. 
Monitoring of movements in civil works.

EFFECTIVE COMMUNICATION

DEFICIENT COMMUNICATION

BASE
KNOWN POINT

GNSS RECEIVER

ROVER
POINT TO BE CALCULATED

GNSS RECEIVER

BASE
KNOWN POINT

GNSS RECEIVER

ROVER
POINT TO BE CALCULATED

GNSS RECEIVER
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3.3.1. RTK LORA BASE

A. CONFIGURATION – AUTOMATIC POSITION

> Enter WiFi Mode
> Select RTK LoRa Method (RTK LoRa)
> Select Base (Base)
> Indicate automatic coordinate input mode (Automatic)
> Select 30 seconds to position the base
> Configure LoRa in group 1 > Save configuration (Save)
> Exit WiFi Mode (Exit)
> Enter Bluetooth Mode

> Enter GNSS Status

> Verify Position and DOP >
 Check in Surveying the position

Measure and Record the base position
> Enter Actions
> Start base to transfer correction data (Start Base)
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Before manual configuration, ensure that the project in FindX5 uses the UTM coordinate 
system of your work zone.

It is recommended to enter the projection coordinates with 3 decimal places and verify the 
conversion to geodetic coordinates.

The entered height can be ellipsoidal or orthometric at the user's discretion.

B. CONFIGURATION – MANUAL POSITION
PROJECTION COORDINATES
> Enter WiFi Mode
> Select RTK LoRa Method (RTK LoRa)
> Select Base (Base)
> Indicate manual coordinate input mode (Manual)
> Select coordinate type Cartographic
> Enter Coordinates East, North and Height
> Verify the conversion to geodetic coordinates latitude and longitude decimal places
> Enter instrument height Inclined(m)
> Configure LoRa in group 1
> Save configuration (Save)
> Exit WiFi Mode (Exit)

> Enter Bluetooth Mode > 
Enter GNSS Status > Verify 
Position and DOP > Enter 
Actions
> Start base to transfer correction data (Start Base)
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C. CONFIGURATION – MANUAL POSITION
GEODETIC COORDINATES

> Enter WiFi Mode

> Select RTK LoRa Method (RTK LoRa) > Select 
Base (Base)

> Indicate in manual coordinate input mode (Manual) > Select
 coordinate type Geographic > Enter Latitude, Longitude and 
Altitude Coordinates > Enter instrument height Inclined(m)
> Configure LoRa in group 1 > Save configuration (Save) > Exit 
WiFi Mode (Exit) > Enter Bluetooth Mode

The entered height can be ellipsoidal or orthometric at the user's discretion.

> Enter GNSS Status
> Verify Position and DOP > 
Enter Actions
> Start base to transfer correction data (Start Base)
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3.3.2. RTK LORA ROVER

A. CONFIGURATION

> Enter WiFi Mode
> Select RTK LoRa Method (RTK LoRa)
> Select Rover (Rover)

> Configure LoRa in group 1 > 
Save configuration (Save)
> Exit WiFi Mode (Exit)
> Enter Bluetooth Mode

B. RTK SURVEY

> Enter Sensor Status (Optional for X5RT)
> Calibrate the sensor IMU Apply Tilt Adjustment (Optional for X5RT)
> Enter Surveying
> Press Measure
> Edit Point Name Point Name
> Edit Point Description Point Description
> Save point Save
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C. RTK STAKEOUT

> Enter Point List

> Select the point to stake out > Select 
the Stakeout icon

Surveying allows you to visualize stakeout displacement
Visual Stakeout Mode visualizes stakeout distance and direction

> Press Measure staked point
> Edit Point Name Point Name
> Edit Point Description Point Description
> Press Record staked point

> Enter Point List > Verify position 
and solution > Exit stakeout mode.
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The FindX5 application allows 2 modes of importing CSV data files.

Mode 01: CSV on the mobile device

> Enter Project

> Verify project storage path > Paste CSV file with the 
project structure

CSV Structure with columns:

1(name), 2(description), 3(data), 4(time), 5(latitude), 6(longitude), 7(altitude), 
8(easting), 9(northing), 10(fixtype), 11(PDOP), 12(SIV), 13(LatError), 
14(LonError), 15(AltError), 16(GeoidAlt), 17(OrthoAlt) and 18(PoleHeight).

D. EXPORT CSV / KML DATA
> Select Export
> Indicate CSV Format

> Indicate the storage path on the user's mobile device > Press Download

E. IMPORT CSV DATA

The required fields are 1(name), 2(description), 8(easting), 9(northing) and 17(OrthoAlt).
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Mode 02: CSV in the cloud

> Enter X5 CLOUD https://cloud.mettatec.com/ 
> Select FindX5 Stakeout
> Upload CSV file

> Correlate CSV data columns > Generate import 
code in Generate
> Enter Project
> Indicate import code Cloud File
> Import points Download
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3.4. RTK NTRIP

Definition:

GNSS real-time positioning method with centimeter accuracy, which uses corrections 
transmitted via the internet (NTRIP protocol) from a reference station or CORS network.

Main Features:

Centimeter accuracy in real time (without post-processing). Internet 
connection required (mobile or WiFi). Eliminates the need for a local 
physical base.

Main Applications:

Precise surveying for photogrammetry, LiDAR, bathymetry, among others. Agile 
surveying for precision agriculture, forestry and cadastre. Auxiliary points for 
construction and alignment of infrastructures. Monitoring of movements in civil 
works.
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ROVER
POINT TO CALCULATE
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3.4.1. RTK NTRIP BASE

A. CONFIGURATION – AUTOMATIC POSITION

> Enter WiFi Mode
> Select RTK NTRIP Method (RTK NTRIP)
> Select Base (Base)
> Indicate the coordinate entry mode as automatic (Automatic)

> Indicate the NTRIP parameters for the base > 
Save configuration (Save)
> Exit WiFi Mode (Exit)
> Enter Bluetooth Mode

> Enter GNSS Status

> Verify Position and DOP >
 Check in Surveying the position

Measure and Record the base position
> Enter Actions
> Start base to transfer correction data (Start Base)
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B. CONFIGURATION – MANUAL POSITION PROJECTION COORDINATES
(See full procedure on page 38)

C. CONFIGURATION – MANUAL POSITION GEODETIC COORDINATES
(See full procedure on page 39)

3.4.2. RTK NTRIP ROVER
A. CONFIGURATION

> Enter WiFi Mode
> Select RTK NTRIP Method (RTK NTRIP)
> Select Rover (Rover)
> Save configuration (Save)
> Exit WiFi Mode (Exit)
> Enter Bluetooth Mode

> Enter GNSS Status

> Verify Position and Solution > 
Enter NTRIP Client
> Enter NTRIP Credentials > Start 
NTRIP connection (Connect)
> Verify NTRIP data reception with Packets
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B. RTK SURVEY
> Enter Sensor Status (Optional for X5RT)
> Calibrate the IMU sensor Apply Tilt Adjustment  (Optional for X5RT) 
> Enter Surveying

> Press Zoom > Press 
Measure
> Edit Point Name Point Name
> Edit Point Description Point Description
> Save point Save

C. RTK STAKEOUT
> Enter Point List

> Select the point to stake out > Select 
the Stakeout icon

Surveying allows you to visualize stakeout displacement
Visual Stakeout Mode visualizes stakeout distance and direction

> Press Measure staked point
> Edit Point Name Point Name
> Edit Point Description Point Description
> Press Save staked point
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> Enter Point List

> Verify position and solution > 
Exit stakeout mode.

D. CSV / KML DATA DOWNLOAD
> Select Export
> Indicate csv format

> Indicate the storage path on the user's mobile device > Press Download

E. IMPORT CSV DATA
The MettaGO application allows 2 ways to Import Data CSV files.

Mode 01: CSV on the mobile device (See full 
procedure page 42)

Mode 02: CSV in the cloud
(See full procedure page 43)
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3.5. LOCAL NTRIP

Definition:

GNSS positioning method that uses the GNSS receiver as a local base to transmit RTK 
corrections via NTRIP protocol, achieving centimeter-level accuracy in real time for 
drones.

Main Features:

Centimeter-level accuracy 1-3 cm in real time in flight (no post-processing). Does not 
depend on the internet or CORS networks (ideal for remote areas).

Main Applications:

Photogrammetry with drones and direct georeferencing of images. LiDAR 
surveys with precision in point clouds.
Precision agriculture in spraying or automated sowing.
Inspection of infrastructures such as power towers, bridges, among others.
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3.5.1. LOCAL NTRIP BASE
A. CONFIGURATION – AUTOMATIC POSITION

> Enter WiFi Mode
> Select Local NTRIP Method (Local NTRIP)
> Indicate automatic coordinate input mode (Automatic)
> Select 30 seconds to position the base

> Verify and record the NTRIP credentials for the drone > 
Save configuration (Save)
> Exit WiFi Mode (Exit)
> Enter Bluetooth Mode

> Enter GNSS Status

> Verify Position and DOP >
 Check in Surveying the position

Measure and Record the base position
> Enter Actions
> Start base to transfer correction data (Start Base)

B. CONFIGURATION – MANUAL POSITION PROJECTED COORDINATES
(See full procedure page 38)

C. CONFIGURATION – MANUAL POSITION GEODETIC COORDINATES (See 
full procedure page 39)
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3.5.2. LOCAL NTRIP AIRCRAFT

A. DJI AIRCRAFT CONFIGURATION WITH RTK MODULE

> Enter the DJI Pilot 2 application or other similar applications
> Access camera view

> Exit pre-flight check > Verify the number of 
satellites tracked.

> Connect via WiFi on the aircraft remote control > Select 
the GNSS X5R / X5RT receiver X5 NTRIP Local + MAC
> Return to the DJI Pilot 2 application
> Enter general settings
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> 
> Enter RTK configuration

Enable RTK Positioning and Maintain positioning accuracy mode
> Select RTK service type in Custom Network RTK
> Select Name and enter Local NTRIP credentials

> Verify connection with Floating or Fixed solution and Standard deviation in decimeters or 
centimeters.

> Successful and accurate connection is verified with Connected Status
> FIX Positioning
> Standard deviation of 1-2 centimeters
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4. GENERAL OPERATIONS

4.1. FIRMWARE UPDATE

The firmware of the GNSS X5R / X5RT receiver is the internal program that controls 
the operations and hardware of the receiver. You can update the firmware of the 
GNSS receiver using the X5Updater.exe software.

Download X5Updater.exe software.

If this is the first time you connect the X5 receiver to your computer, it is necessary to 
install the respective driver.

Download CH34x_Install_Windows.exe driver.

Download X5R.bin firmware. 

We recommend installing the latest version of firmware available, as well as using the 
software and driver in their latest version available in the downloads.

> Connect the X5R / X5RT to your computer
> Open the application "X5Updater"

> Load the firmware file (*.bin) of the version you want to update > Select the COM 
port where the X5 module is connected  “USB-SERIAL CH340”
> Press the "Upload Firmware" button
> The X5 receiver will start the firmware update process.

Video: X5 Firmware Update

https://drive.google.com/drive/folders/1i9rwsPcSggkZzwAzFRV1DdlQziZBb3ch?usp=drive_link
https://drive.google.com/drive/folders/1fk98Uzx8GmnhWnExuvdPo_WOtMJYBw1D?usp=drive_link
https://drive.google.com/drive/folders/1_LWFCEZGDCcPz-49GnYF_6t8YB2FRNG-?usp=drive_link
https://www.youtube.com/watch?v=3JCNIqsXpXE
https://drive.google.com/drive/folders/1i9rwsPcSggkZzwAzFRV1DdlQziZBb3ch?usp=drive_link
https://drive.google.com/drive/folders/1fk98Uzx8GmnhWnExuvdPo_WOtMJYBw1D?usp=drive_link
https://drive.google.com/drive/folders/1_LWFCEZGDCcPz-49GnYF_6t8YB2FRNG-?usp=drive_link
https://www.youtube.com/watch?v=3JCNIqsXpXE
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